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Accounting Exports 
 
 
Important Note About LightSpeed's Accounting Exports 
 
It is important that you understand what LightSpeed is exporting to your accounting 
package, whether it is MYOB or QuickBooks. LightSpeed exports transactions (invoices, 
payments, purchases, inventory adjustments) to the General Ledger (GL) of 
MYOB/QuickBooks as general journal entries. 
 
This means that the export debits and credits the GL accounts that you have linked in 
LightSpeed to Products/Payment Methods/Taxes appropriately as per your transactions. 
It does not export customer data or update customer accounts in these accounting 
packages, nor should you be maintaining customer accounts in these accounting 
packages. Your Accounts Receivable should be managed in LightSpeed. 
 
Accounts Payable is handled in your accounting package and so LightSpeed exports 
more detailed journal entries of your purchases (Supplier Invoices), including your 
supplier list.  Do not delete any Products from your Database that are on unposted 
Invoices, Purchase Orders, or Supplier Invoices.  You will be warned of any errors in 
your export with a dialog box. 
 
Introduction 
 
LightSpeed can export accounting data to  
 

a) MYOB as journal entries 
b) QuickBooks Accounts (MYOB as sold in Canada) as journal entries  
c) QuickBooks for Mac as Journal Entries (format of IIF files) 

 
Before using the Export to MYOB or Export to QuickBooks tools found in the Tools 
menu, you will need to set up LightSpeed with your GL account information by 
following the steps below. 
 
 
Setup 
 
Import Your GL Accounts into LightSpeed 
a) Export your GL accounts from MYOB or QuickBooks. 
  

In MYOB, go to File|Export Data|Accounts|Account Information. Be sure that the 
default settings for the export are “Tab-delimited” for the file format, and “Header 
Record” for the first record. Click Continue.  In the Export Data window that 
appears, click “Match All”, and then “Export”.  Name and save the file. 
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In Quickbooks, the option is found at File|Export|List to IIF File…|Chart of 
Accounts. The settings are automatic. 

 
b) Open the GL Accounts Setup in LightSpeed in Tools|Setup and import the file you 
exported using the button that corresponds with the software you are using 
(Quickbooks or MYOB).  The account names, account numbers, and account types will 
be recognized automatically. 
c) Select GL accounts for Accounts Receivable and Accounts Payable in the Linking 
section. 

 
Note: In Quickbooks, you have to choose between using account names or 
account numbers.   

 

 
 
 
Setup Your Tax Accounts 
a) Open Tools|Setup|Taxes  
b) Select a Collected GL Acct and (if applicable) a Paid GL Acct for the taxes you have 
configured. Note: If your region calculates taxes with each product line item in regards 
to Purchases, check the checkbox marked (2) for that tax. 
 
Setup your Payment Method Accounts 
a) Open Tools|Setup|Payment Method  
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b) Select a GL account for each Payment Method. 
 
Setup your Products 
a) Set the GL Accounts (Income, Inventory/Asset, Expense/COGS) for each Product in 
the Product Window (GL Tab), or by batch using Set Product Info found in the Tools 
menu. You can use the Defaults tab in the GL Accounts Setup window to automatically 
assign GL Accounts when a new Product is created. Note: The Asset and COGS 
accounts for non-inventoried Products will not be visible and cannot be assigned.   
b) To ensure that the GL accounts for your Products are set correctly, run the GL 
reports in the Troubleshooting section of the Reporting window, found in the Tools 
menu. 
 
 
 

 
 

 
Posting 
 
Before Invoices, Payments, or Supplier Invoices (aka Purchases) can be exported, they 
must be Posted.  Effectively, Posting means finalizing a document so that it can no 
longer be edited.  It is important to note that Invoices and Payments are Posted 
separately. 
 
There are two circumstances in which Invoices may be Posted.  If you do not have 
terms with any of your Customers, and each Invoice is paid at the time of the 
transaction, you can check the “Post Invoices When Paid” option in the Company setup 
panel to have Invoices post when paid.  If you do accept credit terms with your 
Customers, and you accept payments to Invoices after the transaction has been 
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completed, you can Post all your Invoices, Payments, and Supplier Invoices over a 
specified date range. 
 

 
 

To Post your Invoices, Payments, and Supplier Invoices, choose the Post By Date 
option of the Edit menu or click the Post By Date button in the Export window. To 
Unpost an Invoice, open the Invoice and choose “Unpost Invoice” from the Edit menu.   
 
 
Exporting To MYOB 
 
Export to MYOB Window 
a) Choose the Export to MYOB option in the Tools menu of LightSpeed 
b) First select which accounting package you are exporting to: MYOB AccountEdge or 
Quickbooks Accounts. 
c) Select the date range for your export. 
d) Select Invoices, Payments, Purchases, and/or Inventory Adjustments and click 
Export. Details on each export are found below. 
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Exporting Invoices 
First, you must select which type of journal entry you prefer to export: Detailed Journal 
Entry or Summarized Journal Entry. 
 
Detailed Journal Entry  
Each Invoice is exported as a separate transaction.  It is VERY IMPORTANT to 
understand that the Invoices are NOT imported into MYOB as Invoices but as journal 
entries that debit or credit the appropriate GL account in MYOB. 
 
If you look at the export file, each entry will have a common journal entry number 
generated by LightSpeed, the date of the journal entry (not the Invoice date), a memo 
containing the original Invoice ID, the GL account number, and the debit or credit 
amount. 
 
Summarized Journal Entry 
All Invoices are exported as a single transaction. If you look at the export file, each entry 
will have a journal entry number generated by LightSpeed, the date of the journal entry, 
the GL account number, and the debit or credit amount. 
 
Both export files have the same structure. The first line of each transaction is the 
Accounts Receivable account, followed by the Income, Tax, COGS, and Inventory 
accounts. The number of lines for each transaction will depend on how your GL 
accounts are set up in LightSpeed.  If all products use the same Income account, you 
will only see one line for Income, etc. 
 
When you export Invoices, you will be asked to save 2 files.  One is Sales (To Import), 
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which is the file you will import into MYOB.  You will also export a detail file, named 
Sales Detail (Do Not Import), where you will find a list of all the exported invoices 
including the Invoice ID, Date, Customer Name, Subtotal, Taxes (Collected Tax 
Accounts) and Total of each Invoice. This detail file will not be imported into MYOB, and 
is simply for your reference.  Note: You can modify the name of these export files if you 
prefer.  
 
Exporting Payments 
Each Payment is exported as a separate transaction (a block of 2 lines in the file) but 
exported together as one single journal entry. If you look at the export file, named 
Payments (To Import), the first line is for the Accounts Receivable account and the 
second line is for the Payment Method account.  Every line will have the same journal 
entry number generated by LightSpeed and the same journal entry date. Each 
transaction will have a memo containing the Invoice ID and the date, the GL account 
number and the debit or credit amount.  Again, you can append the default name of the 
export file to include the date for easier reference, if you prefer. 
 
You have the choice of exporting credit cards and/or cash and checks.  
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Exporting Purchases 
When you export your Supplier Invoices (Purchases) from LightSpeed into MYOB, you 
will be asked if you want to export your Suppliers.  The first time, you must do this 
export, saved as Vendors (To Import), and then import it into MYOB (in MYOB, go to 
File|Import Data|Cards|Vendor Cards). You will also be asked to save 2 files – one 
named Miscellaneous Purchases (To Import), which is the file you will import into 
MYOB (see “Importing to MYOB” below), and another named Supplier Invoices Detail 
(Do Not Import), which is simply for your records.  As above, the file name can be 
modified if you wish.   
 
Note: LightSpeed is able to export multiple payables for the same PO.  Each time you 
receive product on an existing PO, you create and save a new Supplier Invoice.  This 
will allow you to import multiple Supplier Invoices into MYOB for each PO entered in 
LightSpeed. 
 
Each transaction block in the export file corresponds to a Supplier Invoice. The number 
of lines depends on how the GL accounts for taxes (Collected and Paid) are set up in 
LightSpeed. The first line is for the Asset account and the others are for the Tax 
accounts. If you want the taxes (Paid) to be counted separate from the line items, you 
have to set up your GL accounts in Tax Setup accordingly. By default, the taxes are 
counted with the Asset account. 
 

Example: In the US, taxes are counted in the Asset accounts while in Canada, 
some provinces count their Taxes separate from the line items. 

 
If you look at the export file, you will find the Supplier, the PO ID, the PO Date, the GL 
account number, and the amount. 
 
Exporting Inventory Adjustments 
Adjusting your Inventory negatively or positively will affect its value in your accounting 
software. Each adjustment you make must be exported along with your Supplier 
Invoices and Invoices as a credit or debit to your accounting package. The default 
name of this file is Inventory Adjustments (To Import), and also may be edited. 
 
History 
Clicking the History button will open the History drawer, which lists in reverse 
chronological order the exports to MYOB you have done.  The information listed is the 
type of export, its ID, the date range of the export, the user who performed the export, 
and the date the export was performed.   For each entry, there is also a checkbox you 
can select once the export has been performed successfully.  Imports into MYOB 
should only be performed once. 
 
 
Importing To MYOB   
 
Invoices  
a) Go to the Import Data feature under the File menu 
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b) Choose General Journal Entries 
c) Make sure the pull-down menus are set to “Tab Delimited” for Import File Format, 
and “Header Record” for First Record Is.  Click Continue.  
d) Choose the Sales (To Import) file you want to import.  
e) Click “Match All”, and then “Import”. 
 
Payments 
a) Go to the Import Data feature under the File menu 
b) Choose General Journal Entries 
c) Make sure the pull-down menus are set to “Tab Delimited” for Import File Format, 
and “Header Record” for First Record Is.  Click Continue.  
d) Choose the Payments (To Import) file you want to import.  
e) Click “Match All”, and then “Import”. 
 
Purchases 
Important: The first time you do a Purchases import, you must first import the Vendors 
(To Import) file by choosing Import Data > Cards > Vendor Cards, and set your pull-
down menus to “Reject Them” for Duplicate Records, and “Co./Last Name” for Identify 
Records By.  Click “Match All”, then “Import”.  Note: If you add Suppliers, you must re-
do this step.  Any existing Suppliers will be replaced by the current list. 
 
a) Go to the Import Data feature under the File menu 
b) Choose Purchases, and then Miscellaneous Purchases 
c) Make sure the pull-down menus are set to “Tab Delimited” for Import File Format, 
and “Header Record” for First Record Is, and “Reject Them” for Duplicate Records.  
Click Continue.  
d) Choose the Miscellaneous Purchases (To Import) file you want to import.  
e) Click “Match All”, and then “Import”. 
 
Inventory Adjustments 
a) Go to the Import Data feature under the File menu 
b) Choose General Journal Entries 
c) Make sure the pull-down menus are set to “Tab Delimited” for Import File Format, 
and “Header Record” for First Record Is.  Click Continue.  
d) Choose the Inventory Adjustments (To Import) file you want to import.  
e) Click “Match All”, and then “Import”. 
 
 
Exporting To Quickbooks 
 
a) Choose the Export to Quickbooks option in the Tools menu of LightSpeed 
b) First, click on the Account Setup button and select the Sales Tax Vendor for each tax 
you have set up.  These vendors can be found in Quickbooks, and must be entered in 
LightSpeed exactly as they appear on the Vendor List in Quickbooks. Click the Save 
button to save your account settings. Click the Export Setup button to return to the 
main window. 
c) Select the date range for your export. 
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d) Select Invoices, Payments, Purchases, and/or Inventory Adjustments, and click 
Export. 
 

 
 
 
Exporting Invoices 
When you export Invoices, you will be asked to save 2 different files.  The first, named 
Invoices (To Import), is the file you will import into Quickbooks.  You will also export a 
detail file, named Invoices Detail (Do Not Import), where you will find a list of all the 
exported invoices including the Invoice ID, Date, Customer Name, Subtotal, Taxes 
(Collected Tax Accounts) and Total of each Invoice. Note: Rather than exporting 
individual invoices and unique Customer Names for each invoice, LightSpeed exports a 
single summarized Journal Entry with “LightSpeed Export Customer” tagged as the 
Customer in Accounts Receivable. This Customer tag is a requirement in Quickbooks.   
 
Note: You can modify the name of these export files when you save them to reflect the 
date for easier organization of your documents, if you prefer. 
 
 
Exporting Payments 
Each Payment is exported as a separate transaction (a block of 2 lines in the file) but 
exported together as one single journal entry. If you look at the export file, named 
Payments (To Import), the first line is for the Accounts Receivable account and the 
second line is for the Payment Method account.  Every line will have the same journal 
entry number generated by LightSpeed and the same journal entry date. Each 
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transaction will have a memo containing the Invoice ID and the Customer Name, the GL 
account number and the debit or credit amount. Again, you can append the default 
name of the export file to include the date for easier reference, if you prefer. 
 
You have the choice of exporting credit cards and/or cash and checks.  
 
Exporting Purchases 
All the Invoiced POs are exported individually. The QuickBooks Purchases export does 
not yet support multiple payables to be generated and exported per PO. 
 
When you export your PO’s into Quickbooks, you will be asked if you want to export 
your Suppliers.  The first time, you must do this export, saved as Vendors (To Import), 
and then import it into Quickbooks (in Quickbooks, go to File|Import|From IIF Files, and 
then choose this file). You will also be asked to save 2 files – a Supplier Invoices (To 
Import) file, which is the file you will import into Quickbooks (see “Importing to 
Quickbooks” below), and a Supplier Invoices Detail (Do Not Import) file, which is 
simply for your records. As above, this file name can be modified if you wish. 
 
Note: LightSpeed is able to export multiple payables for the same PO.  Each time you 
receive product on an existing PO, you create and save a new Supplier Invoice.  This 
will allow you to import multiple Supplier Invoices into Quickbooks for each PO entered 
in LightSpeed. 
 
Exporting Inventory Adjustments 
Adjusting your Inventory negatively or positively will affect its value in your accounting 
software. Each adjustment you make must be exported along with your Supplier 
Invoices and Invoices as a credit or debit to your accounting package. The default 
name of this file is Inventory Adjustments (To Import), and may be edited to reflect 
the date range of the export. 
 
History 
Clicking the History button will open the History drawer, which lists in reverse 
chronological order the exports to Quickbooks you have done.  The information listed is 
the type of export, its ID, the date range of the export, the user who performed the 
export, and the date the export was performed.   For each entry, there is also a 
checkbox you can select once the export has been performed successfully.  Imports 
into Quickbooks should only be performed once. 
 
 
Importing To Quickbooks   
 
Invoices  
a) Go to the Import feature under the File menu 
b) Choose From IIF Files 
c) Choose the Invoies (To Import) file you want to import.   
 
Payments 
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a) Go to the Import feature under the File menu 
b) Choose From IIF Files 
c) Choose the Payments (To Import) file you want to import.   
 
Purchases 
Important: The first time you do this import, you must first import the Vendors (To 
Import) file, by choosing Import > From IIF Files, and then choosing the Vendors (To 
Import) file. Note: If you add Suppliers, you must re-do this step.  Any existing 
Suppliers will be replaced by the current list. 
 
a) Go to the Import feature under the File menu 
b) Choose From IIF Files 
c) Choose the Supplier Invoices (To Import) file you want to import.   
 
Inventory Adjustments 
a) Go to the Import feature under the File menu 
b) Choose From IIF Files 
c) Choose the Inventory Adjustments (To Import) file you want to import.   
 


